Quick Tip: Fix Library Not Loaded for Node

Quick Tip: Fix Library Not Loaded for Node

If you’ve installed Node via Homebrew and, at any point, are trying to execute a shell script to start up a containerized environment (or maybe something else – I’m speaking solely from my experience) and you’re presented with this message or something like it:

dyld: Library not loaded: /usr/local/opt/icu4c/lib/libicui18n.64.dylib   Referenced from: /usr/local/bin/node   Reason: image not found

Library Not Loaded for Node

Then you should be able to run the following command:

$ brew upgrade node

Or, if you’d like, simply run:

$ brew upgrade

And this will upgrade all of the packages. After that, you can verify that the proper package was installed or upgraded correctly by running:

$ node -v

And then you should see something like the following (depending on when you’re reading this post):

$ v14.3.0

Now you should be able to restart your container or run the script as needed.

Advertisement

About The Author

Tom